Data Status Page

This page contains information about third-party data source disruptions and delays.

Maryland – Statewide and County Search Processing Delays

Incident Report for Checkr Data Status

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2026 - 19:31 UTC

Investigating

Maryland statewide criminal record searches are currently experiencing longer than normal turnaround times due to higher than expected order volume. No ETA for resolution at this time.
Posted Aug 13, 2026 - 18:53 UTC