United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Medina, OH

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 18:32 UTC

Monitoring

Due to an automation update, we are experiencing some website issues in Medina, OH. Searches are being processed manually only at this time. We are monitoring the situation.
Posted Feb 05, 2025 - 18:15 UTC