United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Maryland System Down
Incident Report for Checkr US Data Status
Resolved
09/15/2021: The Maryland online case system is back online and searches are now able to be completed. Please expect some delays as the researchers are working through these.
Posted Sep 15, 2021 - 18:18 UTC
Identified
09/13/2021: The Maryland online system is currently down and ALL searches are unable to be completed at this time. There is no ETA for when this should be back up, but we will continue to monitor this and notify you of any updates. https://www.mdcourts.gov/casesearchoutage
Posted Sep 13, 2021 - 21:01 UTC