United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Lawrence County, Tennessee – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved - normal operations has resumed.
Posted May 26, 2026 - 18:45 UTC

Update

Due to temporary processing delays in Lawrence County, TN, some searches may experience slightly extended turnaround times through May 26.
Posted May 21, 2026 - 00:39 UTC

Monitoring

Due to temporary processing delays in Lawrence County, TN, some searches may experience slightly extended turnaround times through May 26.
Posted May 20, 2026 - 16:18 UTC