United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 19:16 UTC

Monitoring

Counties and States experiencing an ongoing delay due to updated processing, staffing, etc.

--CA: Los Angeles - The online system is having intermittent issues causing some delays for our researchers.

-- CA: Riverside: The court's PATs have been experiencing intermittent issues. Please expect delays on orders.

--MI: The researchers automation is now fixed, but please expect delays as the researchers catch up across the state.

--OH: Jefferson and Licking county searches are delayed due to a site change for the automation, all other counties are fully operational. Please expect some delays while the vendors catch up on queues and fix the automation for the others.

--TX: Denton - The court system is down and all orders with possible cases will be delayed.
Posted Sep 24, 2025 - 19:16 UTC