United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Statewide Florida

Incident Report for Checkr US Data Status

Resolved

Normal operations have resumed.
Posted Apr 17, 2025 - 15:22 UTC

Update

Florida Statewide (FDLE) searches have resumed after experiencing a processing delay. We are now processing searches normally. Please continue to anticipate delays as we work through the backlog.
Posted Apr 16, 2025 - 15:42 UTC

Monitoring

Florida Statewide (FDLE) searches are experiencing a processing delay due to instability of the website and payment system. We are monitoring the situation.
Posted Apr 15, 2025 - 14:46 UTC