United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Harris and Travis, TX

Incident Report for Checkr US Data Status

Update

Please expect delays in Harris and Travis, TX due to frequent crashes and outages of the online index. There is no ETA for restoration. Past delays in Collin and Dallas have since been restored.
We are monitoring the situation.
Posted Mar 25, 2025 - 15:07 UTC

Update

Please expect delays in Collin, Dallas and Travis, TX due to frequent crashes and outages of the online index. There is no ETA for restoration. We are monitoring the situation.
Posted Mar 06, 2025 - 21:14 UTC

Update

Please expect delays in Collin and Travis, TX due to frequent crashes and outages of the online index. We are monitoring the situation.
Posted Feb 21, 2025 - 21:00 UTC

Update

Please expect delays in Collin and Travis, TX due to frequent crashes and outages of the online index. We are monitoring the situation.
Posted Feb 20, 2025 - 18:35 UTC

Monitoring

Please expect delays in Collin, Dallas, and Travis, TX due to frequent crashes and outages of the online index. We are monitoring the situation.
Posted Feb 19, 2025 - 22:15 UTC