[Planned Outage] Oklahoma DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Nov 11, 2022 - 16:49 UTC
Identified
The Oklahoma DMV will be performing scheduled maintenance today from 6-9pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Nov 10, 2022 - 17:48 UTC