United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Cook, IL Outages
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 19:07 UTC
Update
11/1/2021: The entire research community has lost capacity in Cook, IL due to staffing issues among several of the largest researchers servicing the county. Checkr is working with local researchers to increase capacity and improve turnaround time. Please expect delays for the foreseeable future.
Posted Nov 01, 2021 - 16:22 UTC
Monitoring
09/10/2021: The Cook, IL county courts are still experiencing these intermittent minor outages that are causing delays. We will continue to monitor this and notify you of any changes.
Posted Sep 10, 2021 - 20:33 UTC
Identified
09/02/2021: The Cook, IL county courts are experiencing intermittent minor outages that are causing some delays for our researchers, but these outages are entirely unpredictable. Expect delays. We will continue to keep in contact with the courts and notify you of any major outages that last an extended period of time.
Posted Sep 02, 2021 - 22:15 UTC