United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Harrison, MS

Incident Report for Checkr US Data Status

Resolved

The court clerk is back processing orders. Please expect delays as they catch up.
Posted Oct 10, 2025 - 19:44 UTC

Monitoring

The court in Harrison, MS is closed today 10/7 through 10/8 due to an event. No searches will be processed until the court reopens. IF The court plans to reopen on Thursday 10/9. We will continue to monitor the situation and will notify you of any changes.
Posted Oct 07, 2025 - 16:53 UTC