United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Connecticut DMV is offline
Incident Report for Checkr US Data Status
Resolved
The CT DMV is back online and MVRs are now processing.
Posted Jun 28, 2022 - 14:40 UTC
Identified
The Connecticut DMV is offline and MVRs in the state cannot be processed at this time. We are in contact with the state to reestablish connection and will provide updates as they become available.
Posted Jun 28, 2022 - 04:01 UTC