United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] MO DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The MO DMV is back online and MVRs are once again processing.
Posted Dec 02, 2024 - 19:24 UTC
Update
We are continuing to work with the state on a fix for this issue. We are working diligently to ensure accurate and complete data. We currently expect traffic to return to normal 12/2/24.
Posted Nov 27, 2024 - 23:25 UTC
Identified
The MO DMV continues to be offline. We've identified a fix and expect to be online tomorrow, Wednesday, November 27.
Posted Nov 26, 2024 - 21:10 UTC
Investigating
The MO DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Nov 21, 2024 - 17:24 UTC