United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 14:42 UTC
Monitoring
Medium Impact
--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--GA: Bibb - Access to the PATs in the State Court is limited, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.
--NV: Clark - The Henderson municipal site is experiencing slow performance and technical issues, which has impacted automation. We are processing searches but please anticipate delays.
--OH: Cuyahoga - The issue with the Cleveland Heights municipal site has been resolved. We are processing searches but please anticipate delays as our researchers work through the backlog.

Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--KY: Perry - The courthouse will be closed from 11/25 to 11/29 for elevator maintenance. Please expect minor delays during this time.
Posted Nov 27, 2024 - 17:50 UTC