Data Status Page

This page contains information about third-party data source disruptions and delays.

Texas Multi-County - Tropical Storm Court Closures

Incident Report for Checkr Data Status

Resolved

Resolved – Courts across the affected Texas counties have reopened following the tropical storm, and normal search processing has resumed. Some searches may continue to experience delays as the backlog clears.
Posted Sep 09, 2026 - 00:20 UTC

Monitoring

Due to inclement weather, courts across several Texas counties are closed, and searches that require in-court research are not able to be completed until it is safe for the court offices to reopen. Affected counties: Chambers, Hardin, Houston, San Augustine, San Jacinto, Jasper, Jefferson, Liberty, Orange, Polk and Trinity, Tyler and Walker. No ETA at this time.
Posted Sep 02, 2026 - 20:29 UTC