United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Allen, OH

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 15:10 UTC

Monitoring

The Lima Ohio Municipal Court is down for maintenance and the implementation of a new Case Management System. The court is anticipating this update to take roughly 45 days. Searches for Allen County, OH will not be processing at this time. We are monitoring the situation.
Posted Feb 26, 2025 - 21:06 UTC