United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Orange, TX
Incident Report for Checkr US Data Status
Resolved
9/29/2020: The Orange, TX courthouse has reopened. Please expect a delay as we work through the backlog.
Posted Sep 29, 2020 - 18:09 UTC
Identified
Expected Fix Date: TBD

9/15/2020: The Orange, TX courthouse had an air quality test and failed. As a result, the court is closed indefinitely. No searches can be completed at this time.
Posted Sep 15, 2020 - 21:00 UTC