United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Closure - Massachusetts
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 22:30 UTC
Update
There is now full PAT access statewide.
Posted Feb 21, 2024 - 00:51 UTC
Update
PATs are now accessible in a number of courthouses across the state.
Posted Feb 16, 2024 - 17:26 UTC
Update
Courts have now re-opened but PATs remain inaccessible. Please expect continued delays.
Posted Feb 14, 2024 - 18:17 UTC
Monitoring
All courts in the state of Massachusetts will be closed today due to a winter storm. They will reopen tomorrow 2/14. Please expect delays.
Posted Feb 13, 2024 - 17:22 UTC