United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] DOUGHERTY, GA
Incident Report for Checkr US Data Status
Resolved
The Dougherty GA Superior and State Courts have restored access to the public access terminals. Searches have resumed processing.
Posted Oct 29, 2024 - 15:42 UTC
Monitoring
The Dougherty GA Superior and State Courts are currently experiencing a server outage, which has caused the public access terminal to be down. There is no estimated time for restoration, so please anticipate delays
Posted Oct 24, 2024 - 20:23 UTC