United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] - Puerto Rico
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 20:06 UTC
Monitoring
The state police computer system is currently down. This closure affects all searches. Please expect delays. There is no current ETA for a fix. We are continuing to monitor the situation.
Posted Mar 24, 2023 - 15:35 UTC