United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Pennsylvania Statewide Delays
Incident Report for Checkr US Data Status
Resolved
02/18/2021: Pennsylvania online systems are back up and running.
Posted Feb 18, 2021 - 19:29 UTC
Identified
ETA: Unknown

02/11/2021: As of late Monday, the Pennsylvania courts revamped their website. This resulted in all of our vendors having to rebuild their systems. We have confirmed that our vendors have been working with the courts all week to quickly resolve this issue. At this time, we do not have an ETA but will monitor and send updates as we get them. We apologize for any inconvenience this may cause.

*This will affect the completion of all reports*
Posted Feb 11, 2021 - 22:45 UTC