United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Florida Statewide

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 15:09 UTC

Monitoring

We are currently experiencing automation issues for Statewide (FDLE) Searches in Florida which is causing processing delays. We are monitoring the situation.
Posted Apr 22, 2025 - 15:22 UTC