United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - West Virginia

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:13 UTC

Update

WVPass launched on 3/10. Clears and searches with Magistrate hits only will be completed as normal. Circuit hits with all information available will be completed, however if information is not available, clerk assistance will be required which will result in delays. We are unsure if this is the new normal for circuit court hits but are monitoring the situation closely.
Posted Mar 14, 2025 - 15:23 UTC

Monitoring

West Virginia Circuit Court is performing an update on the PAT to remove or redact, all documents containing identifiers beyond name and DOB from circuit court documents. Clears will continue to be processed as normal, possible hits will require clerk assistance. Please anticipate delays. We are monitoring the situation.
Posted Mar 07, 2025 - 22:38 UTC