Data Status Page

This page contains information about third-party data source disruptions and delays.

Monterey County, California – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Automated search processing has been restored. Some searches may experience residual delay as the backlog clears. There is no ETA for resolution at this time.
Posted Sep 14, 2026 - 17:58 UTC

Update

Automated search processing has been restored. Some searches may experience residual delay as the backlog clears. There is no ETA for resolution at this time.
Posted Sep 04, 2026 - 16:46 UTC

Monitoring

System instability has taken some automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Aug 24, 2026 - 17:45 UTC