United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Wisconsin

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 15:31 UTC

Update

Searches are now processing as anticipated. We are monitoring the situation to ensure the automation continues as expected.
Posted Feb 28, 2025 - 15:12 UTC

Monitoring

Automation issues have led to processing delays in Wisconsin. Searches are processing, but there may be delays as we work through the backlog. We are monitoring the situation.
Posted Feb 26, 2025 - 15:23 UTC