United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] PACER

Incident Report for Checkr US Data Status

Update

Searches are processing; however, please anticipate delays as we work through the backlog. We are monitoring the situation.
Posted May 14, 2025 - 15:32 UTC

Monitoring

We are monitoring intermittent issues that may cause delays in some federal searches. Searches are processing but there may be delays. We are monitoring the situation.
Posted May 13, 2025 - 14:32 UTC