Statewide system instability is impacting automated search processing. Searches are currently being fulfilled through a combination of automated and manual processing methods, and some may experience longer-than-normal turnaround times. In some cases, clerk assistance is required, with responses currently taking approximately 1–2 weeks. The current estimated resolution date is June 12
Posted Jun 05, 2026 - 00:53 UTC
Update
Statewide system instability is impacting automated search processing. Searches are currently being fulfilled through a combination of automated and manual processing methods, and some may experience longer-than-normal turnaround times. In some cases, clerk assistance is required, with responses currently taking approximately 1–2 weeks. The current estimated resolution date is June 5.
Posted May 21, 2026 - 16:55 UTC
Monitoring
Statewide system instability is impacting automated search processing. Searches are being fulfilled through a combination of automated and manual processing methods, and some searches may experience longer than normal turnaround times. In addition, statewide court closure in observance of Election Day may result in additional delays. Resolution is expected by May 25.