United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Orange, CA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 20:00 UTC
Identified
Expected Fix Date: TBD

11/12/2020: Orange County, CA is experiencing delays with searches, as all the branches are now closed and all work is going through the main courthouse. Our researchers can still complete work, but please expect delays until all branches reopen. At this time, there is no ETA for the branch re-openings.
Posted Nov 13, 2020 - 00:16 UTC