United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Los Angeles County, CA – Court Processing Delays

Incident Report for Checkr US Data Status

Update

Automated search processing has been restored. Some searches may continue to experience delays as the remaining backlog clears; the backlog is expected to clear by May 11th.
Posted May 08, 2026 - 17:22 UTC

Monitoring

The Los Angeles County court system is experiencing intermittent stability issues impacting automated search processing. Searches are continuing to process with some delays expected. No ETA for resolution at this time.
Posted May 06, 2026 - 21:08 UTC