United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] - Los Angeles, CA
Incident Report for Checkr US Data Status
Update
We are continuing to monitor for any further issues.
Posted Dec 04, 2023 - 23:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 28, 2023 - 23:20 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 21, 2023 - 00:33 UTC
Update
The system transition has caused slowdown in processing searches with possible records. Please expect delays.
Posted Nov 16, 2023 - 16:24 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 07, 2023 - 00:34 UTC
Monitoring
Los Angeles County courthouses are set to undergo a system transition starting the week of November 6th, and it is anticipated that the new system will be fully operational by November 13th. The transition may result in delays on searches with possible records as the court clerks adjust to the new platform.
Posted Oct 31, 2023 - 00:53 UTC