United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Riverside, CA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 16:13 UTC

Update

Riverside, CA Public Access Portal is back online and searches should be processing as normal at this time. We are monitoring the situation until the backlog has recovered.
Posted Mar 26, 2025 - 15:58 UTC

Monitoring

Riverside, CA is currently experiencing an issue with their Public Access Portal and searches are unable to be processed at this time. We are monitoring the situation.
Posted Mar 26, 2025 - 13:59 UTC