United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Lorain, OH
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 27, 2025 - 16:36 UTC
Monitoring
Due to the Lorain Municipal Court's primary index currently not being up to date with case information, we are anticipating delays as searches are paused.
Posted Jan 24, 2025 - 22:43 UTC