United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] IN and OK DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 15:37 UTC
Identified
The following DMVs will be performing scheduled maintenance tomorrow, 9/22, during these times:

Indiana: 3:30-8pm PT
Oklahoma: 6-9pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 21, 2022 - 21:51 UTC