Data Status Page

This page contains information about third-party data source disruptions and delays.

Harrison County, Mississippi – Court Processing Delays

Incident Report for Checkr Data Status

Update

The vendor researcher has returned to office. Please expect delays while the queue clears. No ETA at this time.
Posted Jul 27, 2026 - 15:49 UTC

Update

Processing in Harrison County, MS continues to experience delays due to staffing. Our data providers are actively working through orders with vendor assistance. No ETA at this time.
Posted Jul 20, 2026 - 19:29 UTC

Monitoring

Harrison County, MS is currently experiencing staffing shortages that may impact certain search requests. Most searches will continue to process normally; however, searches requiring clerk assistance, file retrieval, or additional case verification may experience delays. Processing is expected to resume 07/15.
Posted Jul 09, 2026 - 18:43 UTC