United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Maintenance] PACER

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 22:24 UTC

Monitoring

PACER has scheduled maintenance for Sunday, Feb. 9th, from 6:55 a.m. to 7:00 p.m. ET. Service interruptions are expected during this time.
Posted Feb 05, 2025 - 16:11 UTC