United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] - Parker, TX
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 01:44 UTC
Monitoring
The online index is offline, and clerks are unable to provide an ETA for when the site will be functioning. This closure affects all searches.
Please expect delays.
Posted Mar 15, 2023 - 01:39 UTC