Data Status Page

This page contains information about third-party data source disruptions and delays.

Liberty County, Texas – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved- normal search processing has resumed.
Posted Jun 30, 2026 - 06:34 UTC

Update

June 12 Update]: Automated processing is resuming. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 12, 2026 - 21:50 UTC

Monitoring

System instability is impacting some automated search processing. Searches may experience delays. No ETA for resolution at this time.
Posted Jun 11, 2026 - 21:27 UTC