United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 19:39 UTC
Monitoring
Medium Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--GA: The following counties remain closed due to the impact of Hurricane Helene, so please expect delays: Bacon, Berrien, Brantley, Bulloch, Burke, Camden, Chatham, Clinch, Coffee, Columbia, Echols, Emanuel, Evans, Glynn, Jeff Davis, Laurens, Long, Lowndes, McIntosh, Montgomery, Pierce, Richmond, Rockdale, Screven, Toombs, Treutlen, Ware, Washington, and Wheeler.
--GA: Bibb - This county was impacted by a cyberattack and is in the process of restoring public indexes. Researchers are processing searches, but some delays are expected to continue.
--GA: Cobb - There was an internet outage, but it has since been restored and researchers are working through searches. Please expect some delays.
--GA: Muscogee - The court is now open, please anticipate delays as our researchers work through the searches.
--GA: Newton & Rockdale --The counties are closed due to a chemical fire. We are processing orders, but please expect delays.
--MI: Ottawa - All searches now require clerk assistance due to limited information available on the public index. Clerks are restricting submissions to 5 names per day. Please anticipate significant delays.

Low Impact

--LA: St Tammany - The courts have moved to in-court research. Please expect some continued delays.
--NV: Carson City - The Carson City District Court records clerk is behind on requests. Please expect delays.
--NY: Tioga - The research method changed in mid-March. Researchers used to be able to conduct research on a PAT, but now all requests must be submitted to the clerks. Clerks will only process 10 searches a day. Please anticipate delays.
Posted Oct 03, 2024 - 20:15 UTC