United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Hardin, KY
Incident Report for Checkr US Data Status
Resolved
07/27/2022: The Hardin, KY County courthouse is reopened and searches are able to be completed. Please expect some delays as the researchers work through them.
Posted Jul 27, 2022 - 19:38 UTC
Monitoring
07/25/2022: The Hardin, KY County courthouse is currently closed for maintenance and is planning to re-open on July 26th, 2022. This will affect all searches out of this county. Estimate of impacted reports - 0.08%.
Posted Jul 25, 2022 - 17:44 UTC