United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Washington, DC
Incident Report for Checkr US Data Status
Resolved
12/1/2021: The Washington, DC online index is back online and orders are able to be processed. Please see some delays as orders are being worked on.
Posted Dec 01, 2021 - 19:09 UTC
Update
11/24/2021: The Washington, DC online index continues to be offline and researchers are still unable to complete the majority of searches. We are continuing to monitor this and will update you as we know more. *Estimate of impacted reports: 0.4%*
Posted Nov 24, 2021 - 17:21 UTC
Monitoring
11/17/2021: The Washington, DC online index continues to be offline and researchers are still unable to complete the majority of searches. We are continuing to monitor this and will update you as we know more. *Estimate of impacted reports: 0.5%*
Posted Nov 17, 2021 - 16:20 UTC
Identified
11/08/2021: The Washington, DC online index is currently offline and the majority of searches are unable to be completed. The courts are currently assisting with some searches but expect major delays until the online index is back up. Currently, there is no ETA but we will continue to monitor this. *Estimated impacted reports: 0.6%*
Posted Nov 08, 2021 - 17:25 UTC