United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Bibb/GA
Incident Report for Checkr US Data Status
Update
We are continuing to monitor for any further issues.
Posted Jul 22, 2024 - 17:59 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 26, 2024 - 17:56 UTC
Monitoring
Superior and State Court indexes are offline out of an abundance of caution due to a potential cyber-attack. The court is actively adding additional security measures and is investigating the potential breach. While the court confirmed that they are working to resolve the issue as soon as possible there is no ETA at this time. Please expect delays.
Posted May 14, 2024 - 20:05 UTC