United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Riverside CA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 14:45 UTC

Update

The court’s public access terminals continue to experience intermittent issues. Please expect delays as we work through the backlog.
Posted Jul 09, 2025 - 13:35 UTC

Update

The court’s public access terminals are currently down with no estimated time for restoration. Delays should be expected. We are actively monitoring the situation.
Posted Jun 12, 2025 - 15:42 UTC

Update

Automation has been restored in Riverside CA. Please continue to anticipate delays as we work through the backlog.
Posted Jun 10, 2025 - 13:06 UTC

Monitoring

Automation has been paused in Riverside CA. Searches are still processing but there may be delays. We are actively monitoring the situation.
Posted Jun 09, 2025 - 18:49 UTC