United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 16:46 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 3/19:

Rhode Island: 4:30-6am PT
South Carolina: 3-7pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Mar 17, 2023 - 17:57 UTC