United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays

Incident Report for Checkr US Data Status

Update

High Impact
--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.
--MI: Berrien - All searches require clerk assistance due to Michigan Clean Slate Law.
--CA: Riverside - DOB information is no longer accessible on the Riverside Court portal. The new process combines automation with in-court research.
-- AZ: Maricopa - Due to necessary in-court research for confirming case details and PII matching criteria, please anticipate delays.
-- WV: Statewode - Due to the launch of WVPAss, Clears and searches with Magistrate hits only will be completed as normal. Circuit hits with all information available will be completed, however if information is not available, clerk assistance will be required which will result in delays.


Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--TN: Marion - Please expect minor delays due to clerk staffing at the court.
--GA: Bibb - The State Court in Bibb has only two PATs available, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
--NY: Monroe - Due to the NY Clean Slate Laws, our research team is working directly with the clerks.Each researcher is limited to 10 requests per day. Due to this, please expect to see some delays in TAT here.
-- LA: Lafayette - Change in website that has resulted in searches needing to be processed manually. Delays may occur.
-- MI: Kent -The primary index continues to experience outages delaying the completion or orders. The court clerks confirmed awareness of the persistent outage and are working to restore access. Please anticipate delays.
-- GA: Clayton - Please expect delays on Clayton, GA orders due to limited PAT availability at the Superior court and required clerk assistance for additional case information.
-- AR: Monroe - There is a new clerk in place in Monroe, AR. Please anticipate delays as they are getting onboarded.
-- AR: Washington - Searches are delayed in Washington, AR due to court staffing.
-- CA: Stanislaus - Searches that need additional information can only be processed at the clerk's window. Searches are completing but the court limits each researcher to 5 names or 5 cases per day. Please expect delays.
--CA: Santa Clara - Orders requiring additional research cannot be completed via our automation and instead must be handled by a clerk these orders may have extended TATs.


Intermediate
-- OH: Allen - The Lima Ohio Municipal Court is Intermediately down for maintenance and the implementation of a new Case Management System. The court is anticipating this update to take several months and searches may be delayed within this time period.
Posted Mar 25, 2025 - 19:16 UTC

Update

--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.
--MI: Berrien - All searches require clerk assistance due to Michigan Clean Slate Law.
--CA: Riverside - DOB information is no longer accessible on the Riverside Court portal. The new process combines automation with in-court research.
-- AZ: Maricopa - Due to necessary in-court research for confirming case details and PII matching criteria, please anticipate delays.


Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--TN: Marion - Please expect minor delays due to clerk staffing at the court.
--GA: Bibb - The State Court in Bibb has only two PATs available, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
--NY: Monroe - Due to the NY Clean Slate Laws, our research team is working directly with the clerks.Each researcher is limited to 10 requests per day. Due to this, please expect to see some delays in TAT here.
-- LA: Lafayette - Change in website that has resulted in searches needing to be processed manually. Delays may occur.
-- MI: Kent -The primary index continues to experience outages delaying the completion or orders. The court clerks confirmed awareness of the persistent outage and are working to restore access. Please anticipate delays.
-- GA: Clayton - Please expect delays on Clayton, GA orders due to limited PAT availability at the Superior court and required clerk assistance for additional case information.
-- AR: Monroe - There is a new clerk in place in Monroe, AR. Please anticipate delays as they are getting onboarded.
-- AR: Washington - Searches are delayed in Washington, AR due to court staffing.
Posted Mar 11, 2025 - 20:30 UTC

Update

--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.



Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--TN: Marion - Please expect minor delays due to clerk staffing at the court.
--GA: Bibb - The State Court in Bibb has only two PATs available, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
Posted Jan 29, 2025 - 16:13 UTC

Monitoring

--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--GA: Bibb - The State Court in Bibb has only two PATs available, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.


Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--TN: Marion - Please expect minor delays due to clerk staffing at the court.
Posted Jan 08, 2025 - 22:14 UTC