United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Oklahoma DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The Oklahoma DMV is back online and MVRs are now available in the state. Oklahoma MVRs that were ordered during the outage are now being processed.
Posted May 11, 2022 - 18:37 UTC
Update
The Oklahoma DMV has informed us that their maintenance window will be extended through Sunday, May 8. Oklahoma MVRs remain unavailable and will not begin processing again until maintenance is completed.
Posted May 04, 2022 - 22:09 UTC
Update
The Oklahoma DMV informed us that their maintenance continues and is likely to extend until later in the week. MVRs will not be available in the state until maintenance is completed. We will continue to provide updates as they become available.
Posted May 03, 2022 - 14:04 UTC
Update
The Oklahoma DMV has informed us that maintenance will continue until Tuesday, May 3 and MVRs in the state are unavailable until maintenance is completed. We will continue to provide updates as information becomes available.
Posted Apr 29, 2022 - 19:57 UTC
Identified
The Oklahoma DMV is currently offline due to unscheduled maintenance and MVRs in the state are unavailable. We are in contact with the state and will provide updates as information becomes available.
Posted Apr 28, 2022 - 15:28 UTC