Data Status Page

This page contains information about third-party data source disruptions and delays.

DeKalb County, Georgia – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved- normal search processing has resumed.
Posted Aug 11, 2026 - 00:23 UTC

Update

Automation has been restored and normal operations have resumed. Please expect some residual delay as the queue normalizes.
Posted Aug 10, 2026 - 18:47 UTC

Update

Automation has been restored and normal operations have resumed. Please expect some residual delay as the queue normalizes.
Posted Aug 07, 2026 - 20:40 UTC

Update

System instability has taken some automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Aug 07, 2026 - 16:21 UTC

Monitoring

System instability has taken some automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Jul 31, 2026 - 13:50 UTC