United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Monitoring U.S. Government Shutdown and Service Impacts

Incident Report for Checkr US Data Status

Update

We are continuing to closely monitor the U.S. Government Shutdown and are actively assessing any impacts this could have on background check processing and related services. We will provide updates as the situation develops and communicate any necessary changes to service delivery.
Posted Oct 03, 2025 - 14:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 01, 2025 - 15:03 UTC

Update

We are closely monitoring the U.S. Government Shutdown and are actively assessing any impacts this could have on background check processing and related services. We will provide updates as the situation develops and communicate any necessary changes to service delivery.
Posted Oct 01, 2025 - 14:24 UTC

Monitoring

We are closely monitoring the potential U.S. Government Shutdown that may occur at midnight on Wednesday, October 1st. Our team is actively assessing any possible impacts this could have on background check processing and related services. We will provide updates as the situation develops and communicate any necessary changes to service delivery.
Posted Sep 30, 2025 - 18:22 UTC