United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Mississippi DMV Maintenance 11/10-11/12
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 17:41 UTC
Identified
The Mississippi DMV will be performing scheduled maintenance starting today, November 10th at 4pm PT and ending on Saturday, November 12th at 10am PT. MVRs ordered during this time will not be available. Please note that MVRs will be processed once service is restored.
Posted Nov 10, 2022 - 19:27 UTC