United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Georgia STATE DMV is Offline

Incident Report for Checkr US Data Status

Resolved

Georgia DMV is back online and MVRs are once again processing as normal.
Posted Apr 21, 2025 - 13:55 UTC

Update

The Georgia DMV will continue to be offline throughout the weekend. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Apr 19, 2025 - 00:19 UTC

Investigating

The Georgia DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Apr 18, 2025 - 15:22 UTC