[Outage] Pennsylvania DMV is Offline
Incident Report for Checkr Data Status
Resolved
The Pennsylvania DMV came back online last night and MVRs are processing as normal.
Posted Sep 27, 2022 - 16:27 UTC
Identified
The Pennsylvania DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Sep 26, 2022 - 21:59 UTC