United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Hillsborough County, Florida – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved- normal search processing has resumed
Posted May 26, 2026 - 13:28 UTC

Update

Automated search processing has been restored in Hillsborough County. Some searches may continue to experience delays as the remaining backlog clears. The backlog is expected to clear by May 22.
Posted May 20, 2026 - 13:41 UTC

Update

Automated search processing has been restored in Hillsborough County. Some searches may continue to experience delays as the remaining backlog clears. The backlog is expected to clear by May 20.
Posted May 18, 2026 - 15:59 UTC

Update

Automated search processing has been restored. Some searches may continue to experience delays as the remaining backlog clears; monitoring remains active.
Posted May 08, 2026 - 18:38 UTC

Monitoring

Updates to the court portal have impacted automated search processing in Hillsborough County, FL. Searches are continuing to process; however, delays should be expected. No ETA for resolution at this time.
Posted May 05, 2026 - 18:26 UTC